Главный сайт Нижнего Новгорода: Зарегистрируйся, чтобы общаться, знакомиться, искать друзей и получать подарки!
Нижний Новгород on-line
население нижнего новгорода 1.3 млн.ч., интернет аудитория 650 тыс.ч.
16+ : Обсуждение программ 1С, их настройки и методов использования.
0
Фильтр
Тема

Нужна помощь по 1с в решении 3-х задачек

Помогите кому не сложно решить задачки по 1с сам я плохо знаю синтаксис языка - долго провожусь... может кому не сложно по быстрому набросать.

1. Написать обработку, которая будет в выбранном документе «Реализация товаров и услуг» обходить в цикле табличную часть «Товары» и удалять строки, в которых реквизит «Цена» меньше 100.

2. Требуется создать запрос по контрагентам. Должна быть выбрана следующая информация:
1. Код
2. Тип контрагента (Юр./Физ. лицо)
3. Наименование
4. Наименование полное
5. ИНН
6. КПП
7. Фактический адрес
8. Юридический адрес
9. Телефон
10. Номер основного банковского счета
11. Наименование банка
12. БИК
Необходимо, чтобы контактная информация (факт.адрес, юр. адрес, телефон) выводилась в одну строку, но в разных колонках.

Сделать фильтр по группе контрагента.
Для отладки и тестирования можно использовать консоль запроса.

3. Что можно оптимизировать в ниже приведенном коде и почему?Комментарии подписывать по тексту другим цветом.
Процедура ОбработкаПроведения(Отказ, РежимПроведения)

лкЗапрос = Новый Запрос;
лкЗапрос.Текст = "ВЫБРАТЬ
| РеализацияАвтомобилей.Автомобиль,
| РеализацияАвтомобилей.Стоимость,
| РеализацияАвтомобилей.СтоимостьУЕ,
| РеализацияАвтомобилей.Ссылка
|ИЗ
| Документ.РеализацияАвтомобилей.Автомобили КАК РеализацияАвтомобилей";

лкВыборка = лкЗапрос.Выполнить().Выбрать();

Пока лкВыборка.Следующий() Цикл

лкЗапись = Движения.БУ.Добавить();

лкЗапись.СчетДт = лкВыборка.Ссылка.ДоговорВзаиморасчетов.СчетРасчетов;
лкЗапись.СчетКт = ПланыСчетов.БУ.Счет_90_01_1;

лкЗапись.Период = лкВыборка.Ссылка.Дата;
лкЗапись.Регистратор = лкВыборка.Ссылка;
лкЗапись.Сумма = лкВыборка.Стоимость;

Если лкЗапись.СчетДт.Валютный Тогда
лкЗапись.ВалютаДт = лкВыборка.Ссылка.ДоговорВзаиморасчетов.ВалютаУчета;
лкЗапись.ВалютнаяСуммаДт = лкВыборка.СтоимостьУЕ;
КонецЕсли;

лкЗапись.Содержание = "Отражена вырузка по автомобилю " + лкВыборка.Автомобиль.Наименование;

лкЗапись.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконтоБУ.Контрагенты] = лкВыборка.Ссылка.Контрагент;
лкЗапись.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконтоБУ.ДоговорыВзаиморасчетов] = лкВыборка.Ссылка.ДоговорВзаиморасчетов;

лкЗапись.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконтоБУ.ВидыДеятельности] = лкВыборка.Ссылка.ВидДеятельности;
лкЗапись.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконтоБУ.Брэнды] = лкВыборка.Ссылка.Брэнд;
лкЗапись.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконтоБУ.СтавкиНДС] = лкВыборка.СтавкаНДС;

КонецЦикла;

КонецПроцедуры


заранее спасибо
гринатом еще не поменял штоли состав своих задач для собеседования!?)) за два то года!))
видимо нет.
Тесты какие-то ученические.
Интересно, какой ценник гарантируется за решение.
Я тоже искал 1С-ника, получилось найти тут www.modber.ru
Ты устал, голодный, злой — жди: еду везут домой

Не успеваете готовить или просто лень? Или не успеваете в магазин за...

Погуляли: подростка убило электричеством в Сосновском районе

Смертельный случай произошел в селе Лесуново Сосновского района...

Попытка изнасилования в подъезде дома в Сормово попала на видео

Жительница дома по проспекту Союзный едва не стала жертвой насильника....

Выходные в Нижнем Новгороде: едем на гонки!

В эти выходные предлагаем вам посетить благотворительную гонку на...